Hello!

It looks like you're new here. If you want to get involved, click one of these buttons!

[GUIDE] Batman: Arkham Knight

2

Comments

  • How is everyone getting custom resolutions to work in this one? I can only seem to get custom resolutions (NVidia) at 60Hz to work and then every AR is stretching to 16:9.

    Tried falling back to CustomDSRTool but that doesn't want to run with the latest NVidia drivers.
  • I use AMD but I thought it worked the same as DSR (Minus the fancy gaussian shader.) and didn't have any problems but come to think of it I use "standard" resolutions most of the time meaning increments of 25% over the native one.
    (Max on this GPU is 3840x2400 though that's almost unplayable in most newer games outside of Crossfire so I set up those custom increments so I can use 2880x1800 and 3360x2100 instead of 2560x1600 and the for this GPU way too demanding 3840x2400 res.)

    Come to think of it I have no idea how the game would scale if you try something like portraits or what are they called, arbitrary resolutions I think.
    (Trying to force the game to display in a non-standard aspect ratio, useful for screenshots but I thought most games wouldn't be able to properly scale since the majority of them rely on 16:9 almost exclusively meaning for me I get small black bars most of the time.)
  • Yes, it does work the same as the AMD option. I'm able to get DSR working with a 3840x2160 resolution but haven't been able to get an actual custom resolution (with custom timings) work with the game. I've seen that some people are able to get 25MP+ images at different AR's out of this so was wondered what might work.
  • set scaling on GPU to override games in NV control panel , this game runs custom res just like any UE3 game
  • edited January 2016
    Oh! That would have been changed when I updated the drivers recently. Good tip, I'll check that.

    Edit: Thanks, that was the problem. I had to change those settings in Nvida Control Panel and also set "Fullscreen" in the game to see the proper AR.

    image

    Now if only I could get resolutions below 60 Hz to work. Max I can get out of my monitor at 60Hz is 3200x3200.
  • Cheat table link in the OP was busted (and I know jim's busy), could someone who has the cheat table kindly re-upload it somewhere else (like Google drive or Mediafire)?
  • edited April 2016
    I'm not sure if this was the most current but it may do until the link in the OP can be fixed. I've posted what I had to my GDrive.
    https://drive.google.com/file/d/0B0Ad-GMKCuiNOEZKZXRrY2Zvemc/view?usp=sharing

    There's also a merged "pause camera" table Erika and I worked on that works as well. You will need to use a FOV bind to enable FOV control with the table. Pause the game with the main menu and you can move the camera around while paused. I think the HUD toggle was F11 / Ctrl-F11 and you can go into video settings to remove DOF or also into Photomode (works most of the time).
    https://drive.google.com/open?id=0B0Ad-GMKCuiNSUxJeFZkVHRmek0
  • Thanks! Works like a charm. #1 seems busted (game crashed upon enabling free cam script) but #2 is just what I need. Again, much appreciated. :)
    Now I'll try to find a way to combine this with in-game photo mode, I think I can mimic some of the filter effects using ReShade anyway, in case they won't work together at all.
  • Sorry about that first one, looks like it wasn't the most recent one James did. The second one should work with photomode as well. You will need to position the camera before going into photomode though as doing so locks out the camera addresses being used during pause.

    Reshade seems to work fine for me. I think I'm using v2.0.1.
  • Hey. This may not be batman related but the code jim2pointo posted worked for a game i tested out on for unreal engine 3 called saw and worked like a charm :). Im now trying to do it for Medal Of Honor 2010 but it doesnt work for some reason when you push F6-F10? How would i get this to work for Medal Of Honor 2010 which also is a unreal engine 3 game (im using it for singleplayer not mutliplayer which uses frostbite engine). Thanks guys
  • Hi there!! I use the second CE table for BAK, but the FOV don't work, I have changed the key, but with the new key it's not working... I don't understand what the problem... all is working for free cam, but it's impossible to change FOV. Anyone can help??
  • FOV

    This should still work, especially if the pause menu freecam is working. You may need to enable this with the FOV bind and PgDn before going into pause menu.

    1. Enable FOV control with one of the FOV keybinds, this needs to be able to the ini file. (see the OP where F9 and F10 is the example).
    2. Check if the FOV pointer populates with an address and value in the table.
    3. Use the keyboard minus and keyboard plus keys to change value.

  • edited November 2016
    One3rd said:

    FOV

    This should still work, especially if the pause menu freecam is working. You may need to enable this with the FOV bind and PgDn before going into pause menu.

    1. Enable FOV control with one of the FOV keybinds, this needs to be able to the ini file. (see the OP where F9 and F10 is the example).
    2. Check if the FOV pointer populates with an address and value in the table.
    3. Use the keyboard minus and keyboard plus keys to change value.

    Don't work for me :( ...it works the first time i have put the 2 lines F9 & F10 in the good section, BUT Batman can't move after putting the lines in the ini file... he only walk, can't jump, can't fly, can't use weapons... I've try the jim2point0 's solution and copy all the bind key in the other section, but after that FOV don't work....
  • edited November 2016
    I'll have a look later and see if it still works for me. If it does I'll grab my ini file for you to try out.

    I'll have to try this later, in the meantime here is the ini file I use. FOV binds are F3 and F4.
    https://drive.google.com/open?id=0B0Ad-GMKCuiNbUhHaWJpOUh4bFE

    Goes in ..\Steam\steamapps\common\Batman Arkham Knight\BMGame\Config location.
  • Yeah, looks like something may have changed. Even though I had that ini file I wasn't able to use the keybinds and noticed that they had all been removed once exiting the game. To get it working again all I had to do was add them back in under that [BmGame.RPlayerInput] section (I just copied the whole section from the ini file I uploaded for you over the section in the game file) and found that those keybinds now work again when in game. Maybe setting the file to read only might help as well.

    Remember that when using the pause menu you will need to go into the video settings menu to disable DOF. Photo mode also works after you've positioned the camera with the CE keybinds.
Sign In or Register to comment.